WordPress < 5.4.1 - Authenticated Cross-Site Scripting (XSS) in Customizer



Description
Authenticated users could corrupt JSON data in the Customizer of other users' to inject malicious JavaScript.

Affects WordPresses

fixed in version 5.4.1
fixed in version 5.3.3
fixed in version 5.3.3
fixed in version 5.3.3
fixed in version 5.2.6
fixed in version 5.2.6
fixed in version 5.2.6
fixed in version 5.2.6
fixed in version 5.2.6
fixed in version 5.2.6
fixed in version 5.1.5
fixed in version 5.1.5
fixed in version 5.1.5
fixed in version 5.1.5
fixed in version 5.1.5
fixed in version 5.0.9
fixed in version 5.0.9
fixed in version 5.0.9
fixed in version 5.0.9
fixed in version 5.0.9
fixed in version 5.0.9
fixed in version 5.0.9
fixed in version 5.0.9
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.9.14
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.8.13
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.7.17
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.6.18
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.5.21
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.4.22
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.3.23
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.2.27
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.1.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 4.0.30
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.9.31
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.8.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33
fixed in version 3.7.33

References

CVE 2020-11025
URL https://wordpress.org/news/2020/04/wordpress-5-4-1/
URL https://core.trac.wordpress.org/changeset/47633/
URL https://www.wordfence.com/blog/2020/04/unpacking-the-7-vulnerabilities-fixed-in-todays-wordpress-5-4-1-security-update/
URL https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-4mhg-j6fx-5g3c

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Original Researcher Evan Ricafort
Submitter Ryan
Views 4224
Verified No
WPVDB ID 10203

Timeline

Publicly Published 2020-04-29 (27 days ago)
Added 2020-04-30 (25 days ago)
Last Updated 2020-05-02 (23 days ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin