WooCommerce < 4.2.1 - Potential Cross-Site Scripting (XSS) via SelectWoo

Affects Plugin

fixed in version 4.2.1

References

URL https://woocommerce.wordpress.com/2020/06/22/woocommerce-4-2-1-security-and-fix-release/
URL https://github.com/woocommerce/woocommerce/commit/40f7c2d474e242440b2fb9a886353f5a8772a210
URL https://github.com/woocommerce/woocommerce/commit/14a26aca2cde9c81ade02bdc6dd0a34e184a4202
URL https://github.com/woocommerce/selectWoo/releases/tag/1.0.7

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Views 4407
Verified No
WPVDB ID 10282

Timeline

Publicly Published 2020-06-23 (16 days ago)
Added 2020-06-23 (16 days ago)
Last Updated 2020-06-24 (15 days ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin