Broken Link Checker 1.10.1 - Authenticated Stored XSS



Description
On the "Settings > Link Checker > Which Links To Check" screen, the input field 'exclusion_list' is saved without any validation. Malicious JavaScript can be injected.

Screenshots:
http://imgur.com/PsvPQRy
http://imgur.com/nH6GdVN

Affects Plugin

fixed in version 1.10.2

References

URL https://wordpress.org/plugins/broken-link-checker/changelog/

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter SecuBeastTeam
Views 4683
Verified No
WPVDB ID 7707

Timeline

Publicly Published 2014-12-04 (almost 5 years ago)
Added 2014-12-04 (almost 5 years ago)
Last Updated 2019-10-21 (24 days ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin