WP SlimStat <= 3.9.1 - Cross-Site Scripting (XSS)



Description
WP SlimStat Plugin for WordPress is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input.
 
An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.
 
This issue affects WP-SlimStat Plugin 3.9.1; other Old versions may also be vulnerable. 

Sample Payload for Reflected XSS:

http://www.example.com/wordpress/wp-admin/admin.php?page=wp-slim-view-2&fs[resource]=equals+/wordpress/?s='><script>alert("XSS")</script>

Affects Plugin

fixed in version 3.9.2

References

CVE 2015-1204
URL https://wordpress.org/plugins/wp-slimstat/changelog/

Classification

Type XSS
OWASP Top 10 A3: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter LOUDIYI MOHAMED
Views 4030
Verified Yes
WPVDB ID 7744

Timeline

Publicly Published 2015-01-06 (over 4 years ago)
Added 2015-01-06 (over 4 years ago)
Last Updated 2015-05-15 (about 4 years ago)