Revive Old Post <= 6.9.0 - Privilege Escalation

Sign up to our free email alerts service for instant vulnerability notifications!

Description
Leveraging a publicly accessible AJAX function named ‘update_response’, it is possible to update any option with the WordPress installation. Using this vulnerability, it is possible to gain administrative access to the WordPress installation by updating the options ‘default_role’ and ‘users_can_register’, and then creating a new account. This new account will be created with administrative privileges, so long as these two options are updated to the values, as shown in the PoC below.

Affects

Plugin tweet-old-post
fixed in version 6.9.4

References

URL https://research.g0blin.co.uk/g0blin-00024/

Classification

Type AUTHBYPASS
OWASP Top 10 A2: Broken Authentication and Session Management
CWE CWE-287

Miscellaneous

Submitter James Hooker
Submitter Website https://research.g0blin.co.uk
Submitter Twitter g0blinResearch
Views 147
Verified No
WPVDB ID 7780

Timeline

Publicly Published 2015-02-02 (almost 2 years ago)
Added 2015-02-02 (almost 2 years ago)
Last Updated 2015-05-15 (over 1 year ago)

Copyright & License

Copyright All data and resources contained within this page and this web site is Copyright © The WPScan Team.
License Some of this data may be used for non-commercial purposes, however, any potential commercial usage of this data will require a license. If you would like to inquire about a commercial license please contact us.