Twenty Fifteen Theme <= 1.1 - DOM Cross-Site Scripting (XSS)

Sign up to our free email alerts service for instant vulnerability notifications!

Description
Genericons <= 3.2 vulnerable to DOM XSS in the example.html file due to using outdated version of jQuery and vulnerable code.

Vulnerable Code:

permalink = "genericon-" + window.location.hash.split('#')[1];
cssclass = jQuery( '.' + permalink ).attr('class');
Proof of Concept
http://www.example.com/wp-content/themes/twentyfifteen/genericons/example.html#1<img/ src=1 onerror= alert(1)>

Affects

Theme
fixed in version 1.2

References

CVE 2015-3429
PACKETSTORM 131802
URL https://blog.sucuri.net/2015/05/jetpack-and-twentyfifteen-vulnerable-to-dom-based-xss-millions-of-wordpress-websites-affected-millions-of-wordpress-websites-affected.html
URL http://seclists.org/fulldisclosure/2015/May/41

Classification

Type XSS
OWASP Top 10 A3: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 1012
Verified Yes
WPVDB ID 7965

Timeline

Publicly Published 2015-05-06 (over 1 year ago)
Added 2015-05-06 (over 1 year ago)
Last Updated 2015-05-15 (over 1 year ago)

Copyright & License

Copyright All data and resources contained within this page and this web site is Copyright © The WPScan Team.
License Some of this data may be used for non-commercial purposes, however, any potential commercial usage of this data will require a license. If you would like to inquire about a commercial license please contact us.