recent-backups <= 0.7 - Remote File Download



Description
Plugin is still affected and has been closed.

The code in download-file.php does not verify if the user is logged in or sanitize which files can be downloaded. This vulnerability can be used to download sensitive system files, such as the Linux passwd file.
Proof of Concept
$ curl -v "http://www.example.com/wp-content/plugins/recent-backups/download-file.php?file_link=/etc/passwd

Affects Plugin

References

CVE 2015-1000006
EXPLOITDB 37752
PACKETSTORM 132961
URL http://www.vapidlabs.com/advisory.php?v=144

Classification

Type LFI
OWASP Top 10 A1: Injection
CWE CWE-22

Miscellaneous

Submitter Larry W. Cashdollar
Submitter Twitter _larry0
Views 5094
Verified No
WPVDB ID 8122

Timeline

Publicly Published 2015-08-02 (about 4 years ago)
Added 2015-08-03 (about 4 years ago)
Last Updated 2019-08-25 (about 2 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin