WordPress <= 4.2.3 - Legacy Theme Preview Cross-Site Scripting (XSS)

Affects WordPresses

fixed in version 4.2.4
fixed in version 4.2.4
fixed in version 4.2.4
fixed in version 4.2.4
fixed in version 4.1.7
fixed in version 4.1.7
fixed in version 4.1.7
fixed in version 4.1.7
fixed in version 4.1.7
fixed in version 4.1.7
fixed in version 4.1.7
fixed in version 4.0.7
fixed in version 4.0.7
fixed in version 4.0.7
fixed in version 4.0.7
fixed in version 4.0.7
fixed in version 4.0.7
fixed in version 4.0.7
fixed in version 3.9.8
fixed in version 3.9.8
fixed in version 3.9.8
fixed in version 3.9.8
fixed in version 3.9.8
fixed in version 3.9.8
fixed in version 3.9.8
fixed in version 3.9.8
fixed in version 3.8.10
fixed in version 3.8.10
fixed in version 3.8.10
fixed in version 3.8.10
fixed in version 3.8.10
fixed in version 3.8.10
fixed in version 3.8.10
fixed in version 3.8.10
fixed in version 3.8.10
fixed in version 3.8.10
fixed in version 3.7.10
fixed in version 3.7.10
fixed in version 3.7.10
fixed in version 3.7.10
fixed in version 3.7.10
fixed in version 3.7.10
fixed in version 3.7.10
fixed in version 3.7.10
fixed in version 3.7.10
fixed in version 3.7.10
fixed in version 3.7.10

References

CVE 2015-5734
URL https://core.trac.wordpress.org/changeset/33549
URL https://blog.sucuri.net/2015/08/persistent-xss-vulnerability-in-wordpress-explained.html

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 7741
Verified No
WPVDB ID 8133

Timeline

Publicly Published 2015-08-05 (about 4 years ago)
Added 2015-08-05 (about 4 years ago)
Last Updated 2018-08-29 (12 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin