WP REST API (WP API) <= 1.2.2 - Cross-Site Scripting (XSS)



Description
Requests from other origins could potentially run code on the API domain, allowing cross-origin access to authentication cookies or similar.

Affects Plugin

fixed in version 1.2.3
- plugin closed

References

URL http://wptavern.com/wp-rest-api-1-2-3-patches-xss-vulnerability
URL https://github.com/WP-API/WP-API/releases/tag/2.0-beta4

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 6625
Verified No
WPVDB ID 8152

Timeline

Publicly Published 2015-08-14 (almost 5 years ago)
Added 2015-08-14 (almost 5 years ago)
Last Updated 2019-10-22 (9 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin