Photo Gallery by Supsystic <= 1.8.5 - Authenticated Stored Cross-Site Scripting (XSS)



Description
According to the researcher this issue can be exploited by leveraging Cross-Site Request Forgery (CSRF).

Affects Plugin

fixed in version 1.8.6

References

URL http://seclists.org/fulldisclosure/2016/Aug/67
URL https://sumofpwn.nl/advisory/2016/stored_cross_site_scripting_vulnerability_in_photo_gallery_wordpress_plugin.html

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 4046
Verified No
WPVDB ID 8599

Timeline

Publicly Published 2016-08-14 (about 3 years ago)
Added 2016-08-16 (about 3 years ago)
Last Updated 2016-08-16 (about 3 years ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin