WooCommerce <= 2.6.3 - Stored Cross Site Scripting (XSS) via REST API

Affects Plugin

fixed in version 2.6.4

References

URL https://hackerone.com/reports/152692
URL https://sumofpwn.nl/advisory/2016/persistent_cross_site_scripting_in_woocommerce_wordpress_plugin.html
URL https://seclists.org/fulldisclosure/2016/Sep/20

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 5556
Verified No
WPVDB ID 8619

Timeline

Publicly Published 2016-09-09 (about 3 years ago)
Added 2016-09-11 (about 3 years ago)
Last Updated 2019-11-01 (15 days ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin