Google Analytics Counter Tracker <= 3.4.0 - Unauthenticated PHP Object Injection

Affects Plugin

fixed in version 3.5.0
- plugin closed

References

URL https://sumofpwn.nl/advisory/2016/google_analytics_counter_tracker_wordpress_plugin_unauthenticed_php_object_injection_vulnerability.html
URL https://seclists.org/fulldisclosure/2016/Dec/38
URL https://plugins.trac.wordpress.org/changeset/1536434/analytics-counter
URL https://www.pluginvulnerabilities.com/2016/11/15/vulnerability-details-php-object-injection-vulnerability-in-google-analytics-counter-tracker/

Classification

Type OBJECTINJECTION
OWASP Top 10 A8: Insecure Deserialization
CWE CWE-502

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 6632
Verified No
WPVDB ID 8693

Timeline

Publicly Published 2016-11-15 (over 3 years ago)
Added 2016-12-11 (over 3 years ago)
Last Updated 2019-11-01 (8 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin