WordPress 4.7.0-4.7.1 - Unauthenticated Page/Post Content Modification via REST API

Affects WordPresses

fixed in version 4.7.2
fixed in version 4.7.2

References

CVE 2017-1001000
METASPLOIT auxiliary/scanner/http/wordpress_content_injection
URL https://blog.sucuri.net/2017/02/content-injection-vulnerability-wordpress-rest-api.html
URL https://blogs.akamai.com/2017/02/wordpress-web-api-vulnerability.html
URL https://gist.github.com/leonjza/2244eb15510a0687ed93160c623762ab
URL https://github.com/WordPress/WordPress/commit/e357195ce303017d517aff944644a7a1232926f7

Classification

Type BYPASS

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 4997
Verified No
WPVDB ID 8734

Timeline

Publicly Published 2017-02-01 (over 2 years ago)
Added 2017-02-01 (over 2 years ago)
Last Updated 2019-06-05 (4 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin