VaultPress <= 1.8.6 - Backend Server SSL Verification Disabled

Affects Plugin

fixed in version 1.8.7

References

URL https://sumofpwn.nl/advisory/2016/vaultpress___remote_code_execution_via_man_in_the_middle_attack.html
URL https://seclists.org/fulldisclosure/2017/Feb/95
URL https://plugins.trac.wordpress.org/changeset/1607404/vaultpress

Classification

Type UNKNOWN

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 4329
Verified No
WPVDB ID 8745

Timeline

Publicly Published 2017-03-01 (over 3 years ago)
Added 2017-03-02 (over 3 years ago)
Last Updated 2019-11-01 (8 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin