WordPress 3.6.0-4.7.2 - Authenticated Cross-Site Scripting (XSS) via Media File Metadata

Affects WordPresses

fixed in version 4.7.3
fixed in version 4.7.3
fixed in version 4.7.3
fixed in version 4.6.4
fixed in version 4.6.4
fixed in version 4.6.4
fixed in version 4.6.4
fixed in version 4.5.7
fixed in version 4.5.7
fixed in version 4.5.7
fixed in version 4.5.7
fixed in version 4.5.7
fixed in version 4.5.7
fixed in version 4.5.7
fixed in version 4.4.8
fixed in version 4.4.8
fixed in version 4.4.8
fixed in version 4.4.8
fixed in version 4.4.8
fixed in version 4.4.8
fixed in version 4.4.8
fixed in version 4.4.8
fixed in version 4.3.9
fixed in version 4.3.9
fixed in version 4.3.9
fixed in version 4.3.9
fixed in version 4.3.9
fixed in version 4.3.9
fixed in version 4.3.9
fixed in version 4.3.9
fixed in version 4.3.9
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.2.13
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.1.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 4.0.16
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.9.17
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.8.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 3.7.19
fixed in version 4.7.3
fixed in version 4.7.3

References

CVE 2017-6814
URL https://wordpress.org/news/2017/03/wordpress-4-7-3-security-and-maintenance-release/
URL https://github.com/WordPress/WordPress/commit/28f838ca3ee205b6f39cd2bf23eb4e5f52796bd7
URL https://sumofpwn.nl/advisory/2016/wordpress_audio_playlist_functionality_is_affected_by_cross_site_scripting.html
URL https://seclists.org/oss-sec/2017/q1/563

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 8698
Verified No
WPVDB ID 8765

Timeline

Publicly Published 2017-03-06 (almost 3 years ago)
Added 2017-03-07 (almost 3 years ago)
Last Updated 2019-11-01 (about 1 month ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin