WordPress 3.4.0-4.7.4 - Customizer XSS & CSRF

Affects WordPresses

fixed in version 4.7.5
fixed in version 4.7.5
fixed in version 4.7.5
fixed in version 4.7.5
fixed in version 4.7.5
fixed in version 4.6.6
fixed in version 4.6.6
fixed in version 4.6.6
fixed in version 4.6.6
fixed in version 4.6.6
fixed in version 4.6.6
fixed in version 4.5.9
fixed in version 4.5.9
fixed in version 4.5.9
fixed in version 4.5.9
fixed in version 4.5.9
fixed in version 4.5.9
fixed in version 4.5.9
fixed in version 4.5.9
fixed in version 4.5.9
fixed in version 4.4.10
fixed in version 4.4.10
fixed in version 4.4.10
fixed in version 4.4.10
fixed in version 4.4.10
fixed in version 4.4.10
fixed in version 4.4.10
fixed in version 4.4.10
fixed in version 4.4.10
fixed in version 4.4.10
fixed in version 4.3.11
fixed in version 4.3.11
fixed in version 4.3.11
fixed in version 4.3.11
fixed in version 4.3.11
fixed in version 4.3.11
fixed in version 4.3.11
fixed in version 4.3.11
fixed in version 4.3.11
fixed in version 4.3.11
fixed in version 4.3.11
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.2.15
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.1.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 4.0.18
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.9.19
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.8.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 3.7.21
fixed in version 4.7.5
fixed in version 4.7.5
fixed in version 4.7.5
fixed in version 4.7.5
fixed in version 4.7.5
fixed in version 4.7.5
fixed in version 4.7.5
fixed in version 4.7.5

References

CVE 2017-9063
URL https://wordpress.org/news/2017/05/wordpress-4-7-5/
URL https://github.com/WordPress/WordPress/commit/3d10fef22d788f29aed745b0f5ff6f6baea69af3

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 7770
Verified No
WPVDB ID 8820

Timeline

Publicly Published 2017-05-16 (over 2 years ago)
Added 2017-05-17 (over 2 years ago)
Last Updated 2018-08-29 (12 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin