Gravitate QA Tracker <= 1.2.1 - Unauthenticated PHP Object Injection



Description
The plugin gravitate-qa-tracker insecurely trusts serialized data submitted over HTTP requests. This opens up the site to a PHP object injection vulnerability potential exploit vector. 
Proof of Concept
Attack is exploitable over HTTP requests to sites with the gravitate-qa-tracker Plugin.

The original researcher notified WordPress Plugins team.

Affects Plugin

References

CVE 2017-18605
URL https://en-gb.wordpress.org/plugins/gravitate-qa-tracker/

Classification

Type OBJECTINJECTION
OWASP Top 10 A8: Insecure Deserialization
CWE CWE-502

Miscellaneous

Submitter Robert R
Submitter Website https://pagely.com
Submitter Twitter @iamlei
Views 5949
Verified No
WPVDB ID 8824

Timeline

Publicly Published 2017-04-27 (over 2 years ago)
Added 2017-05-21 (over 2 years ago)
Last Updated 2019-11-28 (14 days ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin