My Geo Posts Free <= 1.2 - Unauthenticated PHP Object Injection



Description
The plugin my-geo-posts-free insecurely trusts serialized data submitted over HTTP requests. This opens up the site to a PHP object injection vulnerability potential exploit vector. 
Proof of Concept
Attack is exploitable over HTTP requests to sites with the my-geo-posts-free Plugin.

The original researcher notified WordPress Plugins team.

Affects Plugin

References

URL https://wordpress.org/plugins/my-geo-posts-free/#developers

Classification

Type OBJECTINJECTION
OWASP Top 10 A8: Insecure Deserialization
CWE CWE-502

Miscellaneous

Submitter Robert R
Submitter Website https://pagely.com
Submitter Twitter @iamlei
Views 5453
Verified No
WPVDB ID 8825

Timeline

Publicly Published 2017-04-27 (over 2 years ago)
Added 2017-05-21 (over 2 years ago)
Last Updated 2019-11-01 (about 2 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin