Row Seats Core <= 2.66 - Unauthenticated PHP Object Injection



Description
The plugin row-seats insecurely trusts serialized data submitted over HTTP requests. This opens up the site to a PHP object injection vulnerability potential exploit vector. 

This vulnerability was patched in version 2.68, information is being released now as a disclosure period has expired.
Proof of Concept
Attack is exploitable over HTTP requests to sites with the row-seats Plugin.

Affects Plugin

fixed in version 2.68
- plugin closed

References

URL https://en-gb.wordpress.org/plugins/row-seats/

Classification

Type OBJECTINJECTION
OWASP Top 10 A8: Insecure Deserialization
CWE CWE-502

Miscellaneous

Submitter Robert R
Submitter Website https://pagely.com
Submitter Twitter @iamlei
Views 6520
Verified No
WPVDB ID 8828

Timeline

Publicly Published 2017-04-27 (about 3 years ago)
Added 2017-05-21 (about 3 years ago)
Last Updated 2019-11-01 (9 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin