WordPress 3.0-4.8.1 - Path Traversal in Unzipping



Description
A path traversal vulnerability was discovered in the file unzipping code.

Affects WordPresses

fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.7.6
fixed in version 4.7.6
fixed in version 4.7.6
fixed in version 4.7.6
fixed in version 4.7.6
fixed in version 4.7.6
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.3.12
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.2.16
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.1.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 4.0.19
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.9.20
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.8.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 3.7.22
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.8.2

References

CVE 2017-14719
URL https://hackerone.com/reports/205481
URL https://wordpress.org/news/2017/09/wordpress-4-8-2-security-and-maintenance-release/
URL https://core.trac.wordpress.org/changeset/41457

Classification

Type LFI
OWASP Top 10 A1: Injection
CWE CWE-22

Miscellaneous

Original Researcher Alex Chapman (noxrnet)
Submitter alykode
Views 13524
Verified No
WPVDB ID 8911

Timeline

Publicly Published 2017-09-20 (almost 3 years ago)
Added 2017-09-25 (almost 3 years ago)
Last Updated 2020-01-30 (5 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin