WordPress 4.4-4.8.1 - Cross-Site Scripting (XSS) in oEmbed



Description
A cross-site scripting (XSS) vulnerability was discovered in the oEmbed discovery. Reported by xknown of the WordPress Security Team.

Affects WordPresses

fixed in version 4.8.2
fixed in version 4.8.2
fixed in version 4.7.6
fixed in version 4.7.6
fixed in version 4.7.6
fixed in version 4.7.6
fixed in version 4.7.6
fixed in version 4.7.6
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.6.7
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.5.10
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11
fixed in version 4.4.11

References

CVE 2017-14724
URL https://wordpress.org/news/2017/09/wordpress-4-8-2-security-and-maintenance-release/
URL https://core.trac.wordpress.org/changeset/41448

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter alykode
Views 7148
Verified No
WPVDB ID 8913

Timeline

Publicly Published 2017-09-19 (about 2 years ago)
Added 2017-09-25 (about 2 years ago)
Last Updated 2019-11-01 (about 1 month ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin