Caldera Forms <= 1.5.4 - Authenticated Cross-Site Scripting (XSS)



Description
Version 1.5.4 and earlier of Caldera Forms is vulnerable to a reflected cross-site scripting vulnerability in the “edit” parameter, which is not properly escaped before being printed in an HTML attribute. An attacker can use this to craft URLs that, when clicked, result in malicious JavaScript being executed. Because Caldera Forms uses ‘wp_rest’ nonces to access the WordPress REST API – a common practice among plugin developers – this Javascript may include anything the user is capable of doing in the REST API.
Proof of Concept
[site_url]/wp-admin/admin.php?page=caldera-forms&edit="><script>alert(String.fromCharCode(88%2C83%2C83))<%2Fscript> (1.5.3-4)

[site_url]/wp-admin/admin.php?page=caldera-forms&edit=CF598a16cde8524%3Cimg+url%3D%22%3E%3Cscript%3Ealert%281%29%3C%2Fscript%3E [<1.5.3]

Affects Plugin

fixed in version 1.5.5

References

URL https://calderaforms.com/updates/caldera-forms-1-5-5/

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter Will Brand
Submitter Twitter wrbrand
Views 4450
Verified No
WPVDB ID 8940

Timeline

Publicly Published 2017-09-08 (about 2 years ago)
Added 2017-10-30 (almost 2 years ago)
Last Updated 2019-07-28 (3 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin