Ultimate Instagram Feed <= 1.3.1 - Authenticated Cross-Site Scripting (XSS)



Description
In regards to https://wpvulndb.com/vulnerabilities/8947, the XSS vulnerability remains in 1.3 and 1.3.1 as the author passes _GET['access_token'] to sanitize_text_field(). However, the value is inserted into an attribute of an element, and sanitize_text_field() does not filter for quotes (single or double). Therefore, injecting %22+onblur%3D%22alert%281%29 for access_token will still result in an exploitable injection.  I have reached out to the author but have not received a response yet. I've also contracted the plugin team at WordPress.org
Proof of Concept
While logged in
http://yoursite.com/wp-admin/admin.php?page=ultimate-instagram-feed.php&access_token=%22+onblur%3D%22alert%281%29 

Affects Plugin

References

URL https://wpvulndb.com/vulnerabilities/8947

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter Gilzow
Submitter Website http://missouri.edu
Submitter Twitter gilzow
Views 6977
Verified No
WPVDB ID 8951

Timeline

Publicly Published 2017-11-10 (over 2 years ago)
Added 2017-11-12 (over 2 years ago)
Last Updated 2019-11-01 (8 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin