Yoast SEO <= 5.7.1 - Authenticated Cross-Site Scripting (XSS)



Description
"Cross-site scripting (XSS) vulnerability in admin/google_search_console/class-gsc-table.php in the Yoast SEO plugin before 5.8.0 for WordPress allows remote attackers to inject arbitrary web script or HTML."

Affects Plugin

fixed in version 5.8

References

CVE 2017-16842
URL https://packetstormsecurity.com/files/145080/WordPress-Yoast-SEO-Cross-Site-Scripting.html
URL https://plugins.trac.wordpress.org/changeset/1766831/wordpress-seo/trunk/admin/google_search_console/class-gsc-table.php

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter ethicalhack3r
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 10473
Verified No
WPVDB ID 8960

Timeline

Publicly Published 2017-11-15 (almost 2 years ago)
Added 2017-11-16 (almost 2 years ago)
Last Updated 2018-10-19 (12 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin