UK Cookie Consent <= 2.3.9 - Authenticated Stored Cross-Site Scripting (XSS)



Description
A persistent cross-site scripting vulnerability has been identified in the web interface of the plugin that allows the execution of arbitrary HTML/script code to be executed in a victim's web browser.

Tested on version 2.3.9 (older versions may also be affected)
Proof of Concept
1) Access WordPress control panel.
2) Navigate to the 'Pages'.
3) Add a new page and insert the script you wish to inject into the page title.
4) Now navigate to 'Settings' and select 'Cookie Consent'.
5) Now click on the 'Content' tab.
6) Your injected script will now be executed.

Affects Plugin

fixed in version 2.3.10

References

CVE 2018-10310
URL https://plugins.trac.wordpress.org/changeset/1863058/uk-cookie-consent

Classification

Type XSS
OWASP Top 10 A3: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter B0UG
Views 3999
Verified No
WPVDB ID 9068

Timeline

Publicly Published 2018-04-24 (about 1 year ago)
Added 2018-04-26 (about 1 year ago)
Last Updated 2018-04-26 (about 1 year ago)