Open Graph for Facebook, Google+ and Twitter Card Tags <= 2.2.4 - Authenticated Reflected XSS



Description
There is a reflected XSS vulnerability caused by "Open Graph for Facebook, Google+ and Twitter Card Tags" in the wd_fb_og_error parameter on a GET request when editing a post.

This can be exploited by tricking an authenticated Wordpress administrator into clicking a malicious link.

This vulnerability has been fixed in version 2.2.4.1. To remediate, just update the plugin.
Proof of Concept
Navigate to this link while authenticated as a Wordpress administrator:

https://example.com/wp-admin/post.php?post=20&action=edit&wd_fb_og_status=-2&wd_fb_og_error=<script>alert(1)<%2Fscript>

Affects Plugin

fixed in version 2.2.4.1

References

CVE 2018-0579
URL http://jvn.jp/en/jp/JVN08386386/index.html
URL https://plugins.trac.wordpress.org/changeset/1861290/wonderm00ns-simple-facebook-open-graph-tags

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter hakluke
Submitter Twitter hakluke
Views 4708
Verified No
WPVDB ID 9098

Timeline

Publicly Published 2018-06-20 (about 2 years ago)
Added 2018-06-21 (about 2 years ago)
Last Updated 2019-11-27 (8 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin