WordPress <= 4.9.6 - Authenticated Arbitrary File Deletion



Description
This can lead to code execution if the wp-config.php file is deleted, forcing WordPress to start the installation process.

Can be exploited by any user who is able to edit uploaded media.

Affects WordPresses

fixed in version 4.9.7
fixed in version 4.9.7
fixed in version 4.9.7
fixed in version 4.9.7
fixed in version 4.9.7
fixed in version 4.9.7
fixed in version 4.9.7
fixed in version 4.8.7
fixed in version 4.8.7
fixed in version 4.8.7
fixed in version 4.8.7
fixed in version 4.8.7
fixed in version 4.8.7
fixed in version 4.8.7
fixed in version 4.7.11
fixed in version 4.7.11
fixed in version 4.7.11
fixed in version 4.7.11
fixed in version 4.7.11
fixed in version 4.7.11
fixed in version 4.7.11
fixed in version 4.7.11
fixed in version 4.7.11
fixed in version 4.7.11
fixed in version 4.7.11
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.6.12
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.5.15
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.4.16
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.3.17
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.2.21
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.1.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 4.0.24
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.9.25
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 3.8.27
fixed in version 4.9.7
fixed in version 4.9.7
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27
fixed in version 3.7.27

References

CVE 2018-12895
URL https://blog.ripstech.com/2018/wordpress-file-delete-to-code-execution/
URL http://blog.vulnspy.com/2018/06/27/Wordpress-4-9-6-Arbitrary-File-Delection-Vulnerbility-Exploit/
URL https://github.com/WordPress/WordPress/commit/c9dce0606b0d7e6f494d4abe7b193ac046a322cd
URL https://wordpress.org/news/2018/07/wordpress-4-9-7-security-and-maintenance-release/
URL https://www.wordfence.com/blog/2018/07/details-of-an-additional-file-deletion-vulnerability-patched-in-wordpress-4-9-7/

Classification

Type UNKNOWN

Miscellaneous

Submitter Ryan
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 27197
Verified No
WPVDB ID 9100

Timeline

Publicly Published 2018-06-27 (about 1 year ago)
Added 2018-06-27 (about 1 year ago)
Last Updated 2018-08-29 (about 1 year ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin