WooCommerce <= 3.4.4 - Potential Object Injection



Description
According to WooCommerce:

"Versions 3.4.4 and earlier are affected by an issue where a function that updates attributes could lead to object injection. This is related to the WordPress 4.8.3 security release.

This issue can only be exploited by users who can edit attributes and should not be possible to exploit through the WordPress administrative screens, but we still recommend all users running WooCommerce 3.x upgrade to 3.4.5 to mitigate this issue. Thanks to slavco for responsibly disclosing the vulnerability to us."

Affects Plugin

fixed in version 3.4.5

References

URL https://woocommerce.wordpress.com/2018/08/29/woocommerce-3-4-5-security-fix-release-notes/

Classification

Type OBJECTINJECTION
OWASP Top 10 A8: Insecure Deserialization
CWE CWE-502

Miscellaneous

Submitter Ryan Dewhurst
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 16095
Verified No
WPVDB ID 9120

Timeline

Publicly Published 2018-08-29 (about 1 year ago)
Added 2018-08-30 (about 1 year ago)
Last Updated 2019-11-01 (17 days ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin