WooCommerce <= 3.4.5 - Authenticated File Deletion to Privilege Escalation



Description
Attackers in control of a user with the shop manager role can delete certain files on the server and then take over any victim account.

Affects Plugin

fixed in version 3.4.6

References

CVE 2018-20714
URL https://blog.ripstech.com/2018/wordpress-design-flaw-leads-to-woocommerce-rce/
URL https://woocommerce.wordpress.com/2018/10/11/woocommerce-3-4-6-security-fix-release-notes/
URL https://www.ripstech.com/php-security-calendar-2018/

Classification

Type PRIVESC
OWASP Top 10 A2: Broken Authentication and Session Management
CWE CWE-269

Miscellaneous

Original Researcher Simon Scannell (RIPS Technologies)
Submitter Simon Scannell
Submitter Website https://ripstech.com
Submitter Twitter @scannell_simon
Views 7290
Verified No
WPVDB ID 9143

Timeline

Publicly Published 2018-10-11 (12 months ago)
Added 2018-11-07 (11 months ago)
Last Updated 2019-01-15 (8 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin