Ninja Forms <= 3.3.17 - Unauthenticated Cross-Site Scripting (XSS)



Description
According to the changelog:

"Patched a redirect XSS vulnerability using code injection on our submissions page."

Affects Plugin

fixed in version 3.3.18

References

CVE 2018-19287
URL https://plugins.trac.wordpress.org/changeset/1974335/ninja-forms/trunk/includes/Admin/Menus/Submissions.php

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Original Researcher Unkown
Submitter Ryan Dewhurst
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 7651
Verified No
WPVDB ID 9149

Timeline

Publicly Published 2018-11-14 (10 months ago)
Added 2018-11-15 (10 months ago)
Last Updated 2018-11-15 (10 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin