Advanced Custom Fields <= 5.7.7 - Authenticated Cross-Site Scripting (XSS)



Description
According to the vendor:

"This release contains a fix to a recently reported XSS vunerability [sic]. This report showed it was possible for a logged in author to save unfiltered HTML within a custom field value. This is something that should not be possible without the unfiltered_html capability."

Affects Plugin

fixed in version 5.7.8

References

CVE 2018-20986
ExploitDB 45935
URL https://www.advancedcustomfields.com/blog/acf-5-7-8-release/
URL https://plugins.trac.wordpress.org/changeset/1987429/advanced-custom-fields

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Original Researcher Loading Kura Kura
Submitter Ryan Dewhurst
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 10999
Verified No
WPVDB ID 9163

Timeline

Publicly Published 2018-12-07 (over 1 year ago)
Added 2018-12-10 (over 1 year ago)
Last Updated 2019-11-28 (8 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin