Freemius Library <= 2.2.3 - Authenticated Option Update

Affects Plugins

fixed in version 1.1.4
fixed in version 3.0.9
fixed in version 4.1.9.5
fixed in version 0.7.1
fixed in version 3.3.57
fixed in version 1.6.17
fixed in version 2.5.2
fixed in version 3.0.4
fixed in version 1.3.20
fixed in version 1.4.3
- plugin closed
fixed in version 4.0.5
fixed in version 2.2.3.1
fixed in version 1.1.2
fixed in version 1.9.3
fixed in version 1.6.5
fixed in version 1.6.3
fixed in version 2.18.0
fixed in version 3.3.0
fixed in version 1.4.0
fixed in version 3.2.6
fixed in version 1.7.2

References

URL https://wptavern.com/freemius-patches-severe-vulnerability-in-library-used-by-popular-wordpress-plugins
URL https://freemius.com/blog/sdk-security-vulnerability/
URL https://github.com/Freemius/wordpress-sdk/commit/50a7ca3d921d59e1d2b39bb6ab3c6c7efde494b8
URL https://plugins.trac.wordpress.org/changeset/2039381/

Classification

Type BYPASS

Miscellaneous

Submitter Ryan Dewhurst
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 18617
Verified No
WPVDB ID 9223

Timeline

Publicly Published 2019-02-26 (over 1 year ago)
Added 2019-03-01 (about 1 year ago)
Last Updated 2019-11-01 (7 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin