WPGraphQL <= 0.2.3 - Multiple Vulnerabilities



Description
Without authorisation, weak access controls allow us to:

* Create administrative users
* Post comments on articles bypassing article restrictions and global moderation
* Retrieve content of password-protected posts/articles/pages
* Retrieve full list of registered users in the platform
* Retrieve full list of media, comments, themes and plugins with one simple request

The test was performed locally using WordPress 5.1.1 and WPGraphQL 0.2.3

Affects Plugin

fixed in version 0.3.0

References

CVE 2019-9879
CVE 2019-9880
CVE 2019-9881
URL https://www.pentestpartners.com/security-blog/pwning-wordpress-graphql/
URL https://github.com/pentestpartners/snippets/blob/master/wp-graphql0.2.3_exploit.py
URL https://github.com/wp-graphql/wp-graphql/releases/tag/v0.3.0

Classification

Type MULTI

Miscellaneous

Original Researcher Simone Quatrini
Submitter Simone Quatrini
Submitter Website https://www.pentestpartners.com/security-blog/
Submitter Twitter d0td0tslash
Views 5477
Verified No
WPVDB ID 9282

Timeline

Publicly Published 2019-05-08 (7 months ago)
Added 2019-05-21 (7 months ago)
Last Updated 2019-11-02 (about 1 month ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin