WordPress 5.2.2 - Cross-Site Scripting (XSS) in Stored Comments



Description
From the WordPress version release notes:

"Props to Simon Scannell of RIPS Technologies for finding and disclosing two issues. The first, a cross-site scripting (XSS) vulnerability found in post previews by contributors. The second was a cross-site scripting vulnerability in stored comments."

Affects WordPress

fixed in version 5.2.3

References

CVE 2019-16218
URL https://wordpress.org/news/2019/09/wordpress-5-2-3-security-and-maintenance-release/

Classification

Type XSS
OWASP Top 10 A7: Cross-Site Scripting (XSS)
CWE CWE-79

Miscellaneous

Original Researcher Simon Scannell of RIPS Technologies
Views 23433
Verified No
WPVDB ID 9861

Timeline

Publicly Published 2019-09-05 (2 months ago)
Added 2019-09-05 (2 months ago)
Last Updated 2019-09-11 (2 months ago)

Our Other Services

Online WordPress Vulnerability Scanner WPScan WordPress Security Plugin