WordPress 3.0.2 Vulnerabilities

Vulnerabilities

2017-11-30 WordPress 1.5.0-4.9 - RSS and Atom Feed Escaping fixed in version 4.9.1
2017-11-30 WordPress 2.8.6-4.9 - Authenticated JavaScript File Upload fixed in version 4.9.1
2017-10-31 WordPress <= 4.8.2 - $wpdb->prepare() Weakness fixed in version 4.8.3
2017-09-25 WordPress 3.0-4.8.1 - Path Traversal in Unzipping fixed in version 4.8.2
2017-09-25 WordPress 2.9.2-4.8.1 - Open Redirect fixed in version 4.8.2
2017-09-20 WordPress 2.3.0-4.7.4 - Authenticated SQL injection fixed in version 4.7.5
2017-09-20 WordPress 2.3.0-4.8.1 - $wpdb->prepare() potential SQL Injection fixed in version 4.8.2
2017-05-17 WordPress 2.5.0-4.7.4 - Filesystem Credentials Dialog CSRF fixed in version 4.7.5
2017-05-17 WordPress 2.5.0-4.7.4 - Post Meta Data Values Improper Handling in XML-RPC fixed in version 4.7.5
2017-05-17 WordPress 2.7.0-4.7.4 - Insufficient Redirect Validation fixed in version 4.7.5
2017-05-05 WordPress 2.3-4.8.3 - Host Header Injection in Password Reset
2017-03-07 WordPress 2.8.1-4.7.2 - Control Characters in Redirect URL Validation fixed in version 4.7.3
2017-01-12 WordPress 3.0-4.7 - Cryptographically Weak Pseudo-Random Number Generato... fixed in version 4.7.1
2017-01-12 WordPress 2.8-4.7 - Accessibility Mode Cross-Site Request Forgery (CSRF) fixed in version 4.7.1
2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default fixed in version 4.7.1
2017-01-12 WordPress 2.9-4.7 - Authenticated Cross-Site scripting (XSS) in update-c... fixed in version 4.7.1
2016-09-08 WordPress 2.8-4.6 - Path Traversal in Upgrade Package Uploader fixed in version 4.6.1
2016-09-08 WordPress 2.5-4.6 - Authenticated Stored Cross-Site Scripting via Image ... fixed in version 4.6.1
2016-06-21 WordPress 2.6.0-4.5.2 - Unauthorized Category Removal from Post fixed in version 4.5.3
2016-04-28 WordPress <= 4.4.2 - Script Compression Option CSRF fixed in version 4.5
2016-04-28 WordPress <= 4.4.2 - Reflected XSS in Network Settings fixed in version 4.5
2016-04-28 WordPress <= 4.4.2 - SSRF Bypass using Octal & Hexedecimal IP addresses fixed in version 4.5
2015-07-23 WordPress <= 4.2.2 - Authenticated Stored Cross-Site Scripting (XSS) fixed in version 4.2.3
2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF) fixed in version 4.0.1
2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS) fixed in version 4.0.1
2014-11-20 WordPress 3.0-3.9.2 - Unauthenticated Stored Cross-Site Scripting (XSS) fixed in version 4.0
2014-09-16 WordPress 3.0 - 3.9.1 Authenticated Cross-Site Scripting (XSS) in Multisite fixed in version 3.9.2
2014-09-16 WordPress 2.0.3 - 3.9.1 (except 3.7.4 / 3.8.4) CSRF Token Brute Forcing fixed in version 3.9.2
2014-08-01 WordPress XML-RPC Interface Access Restriction Bypass
2014-08-01 WordPress <= 3.0.5 wp-admin/press-this.php Privilege Escalation fixed in version 3.0.6
2014-08-01 WordPress 2.5 - 3.3.1 XSS in swfupload fixed in version 3.3.2
2014-08-01 WordPress <= 3.3.2 Cross-Site Scripting (XSS) in wp-includes/default-fil... fixed in version 3.3.3
2014-08-01 WordPress <= 3.3.2 wp-admin/media-upload.php sensitive information discl... fixed in version 3.3.3
2014-08-01 WordPress <= 3.3.2 wp-admin/includes/class-wp-posts-list-table.php sensi... fixed in version 3.3.3
2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning fixed in version 3.5.1
2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
2014-08-01 WordPress 3.0 - 3.6 Crafted String URL Redirect Restriction Bypass fixed in version 3.6.1