WordPress Vulnerabilities

Version Added Title
2.0.4 2014-08-01 WordPress 2.0 - 2.7.1 admin.php Module Configuration Security Bypass
2.0.4 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
2.0.4 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
2.0.4 2014-08-01 WordPress 2.0.2 - 2.0.4 Paged Parameter SQL Injection
2.0.4 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/comment.php Bypass Spam Restrictions
2.0.4 2014-08-01 WordPress 2.0 - 3.0.1 Multiple Cross-Site Scripting (XSS) in request_filesyst...
2.0.4 2014-08-01 WordPress 2.0 - 3.0.1 Cross-Site Scripting (XSS) in wp-admin/plugins.php
2.0.4 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/capabilities.php Remote Authenticated Admin...
2.0.4 2014-08-01 WordPress 2.0 - 3.0 Remote Authenticated Administrator Add Action Bypass
2.0.4 2014-09-16 WordPress 2.0.3 - 3.9.1 (except 3.7.4 / 3.8.4) CSRF Token Brute Forcing
2.0.4 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
2.0.4 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
2.0.4 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
2.0.3 2014-08-01 WordPress 2.0 - 2.7.1 admin.php Module Configuration Security Bypass
2.0.3 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
2.0.3 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
2.0.3 2014-08-01 WordPress 2.0.2 - 2.0.4 Paged Parameter SQL Injection
2.0.3 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/comment.php Bypass Spam Restrictions
2.0.3 2014-08-01 WordPress 2.0 - 3.0.1 Multiple Cross-Site Scripting (XSS) in request_filesyst...
2.0.3 2014-08-01 WordPress 2.0 - 3.0.1 Cross-Site Scripting (XSS) in wp-admin/plugins.php
2.0.3 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/capabilities.php Remote Authenticated Admin...
2.0.3 2014-08-01 WordPress 2.0 - 3.0 Remote Authenticated Administrator Add Action Bypass
2.0.3 2014-09-16 WordPress 2.0.3 - 3.9.1 (except 3.7.4 / 3.8.4) CSRF Token Brute Forcing
2.0.3 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
2.0.3 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
2.0.3 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
2.0.2 2014-08-01 WordPress 2.0 - 2.7.1 admin.php Module Configuration Security Bypass
2.0.2 2014-08-01 WordPress <= 2.0.2 (cache) Remote Shell Injection Exploit
2.0.2 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
2.0.2 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
2.0.2 2014-08-01 WordPress 2.0.2 - 2.0.4 Paged Parameter SQL Injection
2.0.2 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/comment.php Bypass Spam Restrictions
2.0.2 2014-08-01 WordPress 2.0 - 3.0.1 Multiple Cross-Site Scripting (XSS) in request_filesyst...
2.0.2 2014-08-01 WordPress 2.0 - 3.0.1 Cross-Site Scripting (XSS) in wp-admin/plugins.php
2.0.2 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/capabilities.php Remote Authenticated Admin...
2.0.2 2014-08-01 WordPress 2.0 - 3.0 Remote Authenticated Administrator Add Action Bypass
2.0.2 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
2.0.2 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
2.0.2 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
2.0.11 2014-08-01 WordPress 2.0 - 2.7.1 admin.php Module Configuration Security Bypass
2.0.11 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
2.0.11 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
2.0.11 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/comment.php Bypass Spam Restrictions
2.0.11 2014-08-01 WordPress 2.0 - 3.0.1 Multiple Cross-Site Scripting (XSS) in request_filesyst...
2.0.11 2014-08-01 WordPress 2.0 - 3.0.1 Cross-Site Scripting (XSS) in wp-admin/plugins.php
2.0.11 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/capabilities.php Remote Authenticated Admin...
2.0.11 2014-08-01 WordPress 2.0 - 3.0 Remote Authenticated Administrator Add Action Bypass
2.0.11 2014-09-16 WordPress 2.0.3 - 3.9.1 (except 3.7.4 / 3.8.4) CSRF Token Brute Forcing
2.0.11 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
2.0.11 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
2.0.11 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
2.0.10 2014-08-01 WordPress 2.0 - 2.7.1 admin.php Module Configuration Security Bypass
2.0.10 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
2.0.10 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
2.0.10 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/comment.php Bypass Spam Restrictions
2.0.10 2014-08-01 WordPress 2.0 - 3.0.1 Multiple Cross-Site Scripting (XSS) in request_filesyst...
2.0.10 2014-08-01 WordPress 2.0 - 3.0.1 Cross-Site Scripting (XSS) in wp-admin/plugins.php
2.0.10 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/capabilities.php Remote Authenticated Admin...
2.0.10 2014-08-01 WordPress 2.0 - 3.0 Remote Authenticated Administrator Add Action Bypass
2.0.10 2014-09-16 WordPress 2.0.3 - 3.9.1 (except 3.7.4 / 3.8.4) CSRF Token Brute Forcing
2.0.10 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
2.0.10 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
2.0.10 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
2.0.1 2014-08-01 Wordpress 1.5.1 - 2.0.2 wp-register.php Multiple Parameter XSS
2.0.1 2014-08-01 WordPress 2.0 - 2.7.1 admin.php Module Configuration Security Bypass
2.0.1 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
2.0.1 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
2.0.1 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/comment.php Bypass Spam Restrictions
2.0.1 2014-08-01 WordPress 2.0 - 3.0.1 Multiple Cross-Site Scripting (XSS) in request_filesyst...
2.0.1 2014-08-01 WordPress 2.0 - 3.0.1 Cross-Site Scripting (XSS) in wp-admin/plugins.php
2.0.1 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/capabilities.php Remote Authenticated Admin...
2.0.1 2014-08-01 WordPress 2.0 - 3.0 Remote Authenticated Administrator Add Action Bypass
2.0.1 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
2.0.1 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
2.0.1 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
2.0 2014-08-01 Wordpress 1.5.1 - 2.0.2 wp-register.php Multiple Parameter XSS
2.0 2014-08-01 WordPress 2.0 - 2.7.1 admin.php Module Configuration Security Bypass
2.0 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
2.0 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
2.0 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/comment.php Bypass Spam Restrictions
2.0 2014-08-01 WordPress 2.0 - 3.0.1 Multiple Cross-Site Scripting (XSS) in request_filesyst...
2.0 2014-08-01 WordPress 2.0 - 3.0.1 Cross-Site Scripting (XSS) in wp-admin/plugins.php
2.0 2014-08-01 WordPress 2.0 - 3.0.1 wp-includes/capabilities.php Remote Authenticated Admin...
2.0 2014-08-01 WordPress 2.0 - 3.0 Remote Authenticated Administrator Add Action Bypass
2.0 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
2.0 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
2.0 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
1.5.2 2014-08-01 Wordpress 1.5.1 - 2.0.2 wp-register.php Multiple Parameter XSS
1.5.2 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
1.5.2 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
1.5.2 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
1.5.2 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
1.5.2 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
1.5.1.3 2014-08-01 Wordpress 1.5.1 - 2.0.2 wp-register.php Multiple Parameter XSS
1.5.1.3 2014-08-01 Wordpress <= 1.5.1.3 Remote Code Execution eXploit (metasploit)
1.5.1.3 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
1.5.1.3 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
1.5.1.3 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
1.5.1.3 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
1.5.1.3 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
1.5.1.2 2014-08-01 Wordpress 1.5.1 - 2.0.2 wp-register.php Multiple Parameter XSS
1.5.1.2 2014-08-01 WordPress <= 1.5.1.2 - XMLRPC SQL Injection
1.5.1.2 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
1.5.1.2 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
1.5.1.2 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
1.5.1.2 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
1.5.1.2 2015-01-23 WordPress <= 1.5.1.2 - XMLRPC Eval Injection
1.5.1.2 2015-01-23 WordPress <= 1.5.1.2 - Multiple Cross-Site Scripting (XSS)
1.5.1.2 2015-01-23 WordPress <= 1.5.1.2 - Email Spoofing
1.5.1.2 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
1.5.1.1 2014-08-01 Wordpress 1.5.1 - 2.0.2 wp-register.php Multiple Parameter XSS
1.5.1.1 2014-08-01 WordPress <= 1.5.1.1 "add new admin" SQL Injection Exploit
1.5.1.1 2014-08-01 WordPress <= 1.5.1.1 SQL Injection Exploit
1.5.1.1 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
1.5.1.1 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
1.5.1.1 2014-09-27 WordPress 1.5 & 1.5.1.1 - SQL Injection
1.5.1.1 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
1.5.1.1 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
1.5.1.1 2015-01-23 WordPress <= 1.5.1.2 - XMLRPC Eval Injection
1.5.1.1 2015-01-23 WordPress <= 1.5.1.2 - Multiple Cross-Site Scripting (XSS)
1.5.1.1 2015-01-23 WordPress <= 1.5.1.2 - Email Spoofing
1.5.1.1 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
1.5.1 2014-08-01 Wordpress 1.5.1 - 2.0.2 wp-register.php Multiple Parameter XSS
1.5.1 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC Pingback API Internal/External Port Scanning
1.5.1 2014-08-01 WordPress 1.5.1 - 3.5 XMLRPC pingback additional issues
1.5.1 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
1.5.1 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
1.5.1 2015-01-23 WordPress <= 1.5.1.2 - XMLRPC Eval Injection
1.5.1 2015-01-23 WordPress <= 1.5.1.2 - Multiple Cross-Site Scripting (XSS)
1.5.1 2015-01-23 WordPress <= 1.5.1.2 - Email Spoofing
1.5.1 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
1.5 2014-08-01 WordPress 1.5 wp-trackback.php tb_id Parameter SQL Injection
1.5 2014-08-01 WordPress <= 1.5 Multiple Vulnerabilities (XSS, SQLi)
1.5 2014-08-01 WordPress 1.5 template-functions-post.php Multiple Field XSS
1.5 2014-09-27 WordPress 1.5 & 1.5.1.1 - SQL Injection
1.5 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
1.5 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
1.5 2015-01-23 WordPress <= 1.5.1.2 - XMLRPC Eval Injection
1.5 2015-01-23 WordPress <= 1.5.1.2 - Multiple Cross-Site Scripting (XSS)
1.5 2015-01-23 WordPress <= 1.5.1.2 - Email Spoofing
1.5 2017-01-12 WordPress <= 4.7 - Post via Email Checks mail.example.com by Default
1.2.1 2014-09-27 WordPress 1.2-1.2.1 - Multiple Cross-Site Scripting (XSS)
1.2.1 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
1.2.1 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
1.2.1 2015-01-23 WordPress <= 1.5.1.2 - XMLRPC Eval Injection
1.2.1 2015-01-23 WordPress <= 1.5.1.2 - Multiple Cross-Site Scripting (XSS)
1.2.1 2015-01-23 WordPress <= 1.5.1.2 - Email Spoofing
1.2 2014-09-27 WordPress 1.2-1.2.1 - Multiple Cross-Site Scripting (XSS)
1.2 2014-09-27 WordPress 1.2 - HTTP Response Splitting
1.2 2014-11-20 WordPress <= 4.0 - Long Password Denial of Service (DoS)
1.2 2014-11-30 WordPress <= 4.0 - Server Side Request Forgery (SSRF)
1.2 2015-01-23 WordPress <= 1.5.1.2 - XMLRPC Eval Injection
1.2 2015-01-23 WordPress <= 1.5.1.2 - Multiple Cross-Site Scripting (XSS)
1.2 2015-01-23 WordPress <= 1.5.1.2 - Email Spoofing
0.70 2015-03-01 WordPress 0.7 - SQL Injection